The API requires both .NET framework 3.5 and the latest service pack of .NET framework 2.0 to run (this is because later versions of the framework build on version 2.0). The service pack of .NET framework 2.0 is usually upgraded when .NET framework 3.5 is installed, but not always.
A clue is the .NET Framework version shown at the bottom of the error screen. In this example, it is 2.0.50727.42, which is the original released .NET framework 2.0, without any service packs. There is a list of what versions correspond with what .NET framework service packs here: http://blogs.msdn.com/b/astebner/archive/2005/07/12/438245.aspx
.NET Framework SP2 can be downloaded from: http://www.microsoft.com/downloads/details.aspx?familyid=5B2C0358-915B-4EB5-9B1D-10E506DA9D0F&displaylang=en