Print Friendly and PDF

Troubleshooting: "Child nodes not allowed" error in web.config when running the API

The API requires both .NET framework 3.5 and the latest service pack of .NET framework 2.0 to run (this is because later versions of the framework build on version 2.0). The service pack of .NET framework 2.0 is usually upgraded when .NET framework 3.5 is installed, but not always.

A clue is the .NET Framework version shown at the bottom of the error screen. In this example, it is 2.0.50727.42, which is the original released .NET framework 2.0, without any service packs. There is a list of what versions correspond with what .NET framework service packs here:

.NET Framework SP2 can be downloaded from:

Back to Top
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request


Please sign in to leave a comment.