Print Friendly and PDF
Follow

VETtrak Version 18.2 - TLS Upgrade/Windows Operating System Support

From VETtrak Version 18.2 (to be released in late April 2018) VETtrak will no longer officially support the following operating systems:

  • Windows XP, or


  • Windows Server 2003 


The following will be the minimum supported operating systems for VETtrak 18.2: 

  • Windows Vista SP2 (Service Pack 2), or
    Image result for Windows Vista SP2 logo

  • Windows 7 SP1 (Service Pack 1), and
    Image result for Windows 7 logo

  • Windows Server 2008 SP2 (Service Pack 2)

 

This is due to VETtrak adding support for TLS 1.2 (which requires .NET Framework 4.5 or later) in VETtrak 18.2. Windows XP and Windows Server 2003 are not able to support TLS 1.2, which will be required moving forward - as the USI office has flagged that they will soon only support the use of TLS 1.2 for the USI web services due to security concerns.

Check this page to see if your system meets the requirements for .NET Framework 4.5 or higher: https://docs.microsoft.com/en-us/dotnet/framework/get-started/system-requirements

TLS versions 1.0 and 1.1 will no longer be supported from Sunday, 22 July 2018.

It is recommended that all VETtrak customers should ensure that any/all servers and workstations running VETtrak meet the new minimum supported operating systems prior to updating to 18.2. It is also recommended that once this has been confirmed and VETtrak 18.2 is released, VETtrak should be updated to version 18.2 to ensure continued access the USI web services. 

The change to the minimum supported operating systems does not affect hosted VETtrak customers. Our servers already meet the minimum requirement, and as you connect remotely to the servers, the operating system of your computer is not an issue. Hosted customers should request to be updated to 18.2 when it released. This also does not affect computers that are only accessing VETtrak through the web portals, such as the Trainer Portal or Progress Portal.

There is no need to confirm with us that you meet the minimum supported operating systems. If you are in doubt of the operating systems in use in your network, we recommend that you check with your IT service provider.

Once this change has gone live, you will likely encounter the following error:

Area Code Message Explanation/resolution
General The requested security protocol is not supported.

The USI office has flagged that they will only support the use of TLS 1.2 for the USI web services due to security concerns.

This requires an installation of the Microsoft .NET Framework 4.5, available to users on Windows Vista (Service Pack 2), Windows 7 (Service Pack 1) or Windows Server 2008 SP2.

If you have any questions regarding these upcoming changes, please contact VETtrak Support on ☎ 1800 VETTRAK or ✉ support@vettrak.com.au

 

Back to Top
    Tags:
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.